• Instalar ServiceBox 2013

  • Espacio dedicado a las INSTRUCCIONES de cómo codificar, configurar o diagnosticar desde Lexia y DiagBox.

Por favor, no utilices mensajes privados o WhatsApp para resolver tus dudas. ¡Compártelas! Nuestro sentido es transmitir sabiduría. Si lo haces en privado, mañana no estará disponible.
Espacio dedicado a las INSTRUCCIONES de cómo codificar, configurar o diagnosticar desde Lexia y DiagBox.
 #202077  por tatel
 18 Feb 2018, 19:18
Ante todo, comentar que yo ahora mismo debería estar de viaje con destino a la capital del Turia pero ayer tarde descubrí que un hijo de puta se ha llevado por delante mi retrovisor izquierdo, sin dejar nota ni nada, así que tendré que retrasarlo hasta que me llegue otro del desguace... Entretanto, ya que tengo tiempo, paso a abrir un hilo acerca de ServiceBox.

Ya me fastidia decir esto, pero tras 28 años ganándome la vida con ordenadores, no soy capaz de averiguar porqué el SEDRE (esquemas eléctricos) funciona solamente cuando le sale de los c... Hay un buen montón de incidencias, así que perdonad, pero el post va a ser largo. Si no estáis metidos en el tema... mejor pasad a otro post.

No nos equivoquemos, tengo una instalación funcionando bajo virtualbox en la que funciona todo el servibox + diagbox hasta la 8.55, con instantáneas tomadas a cada actualización desde la 7.57. Pero una segunda instalación de servicebox en otra máquina (que pensaba dejar en el garage de mi madre) se ha puesto tonta, con la típica incidencia de que no se pueden ver los esquemas de SEDRE, mientras que DocBackup funciona sin problemas.

Así que esto es una cuestión de suerte, chiripa y de quién ha pagado más al brujo que se encarga de hacer el juju, y ésta no es la manera en que las cosas han de funcionar cuando son serias.

Tras poner en práctica todo lo encontrado en los foros... nada. A estas alturas pienso que el fallo se produce, no en los navegadores sino en el propio servidor Apache-Tomcat-Java. Quizá algún día, si estoy aburrido y no encuentro nada mejor que hacer, me ponga a explorar por ahí a ver qué sale. Por ahora, voy a dejar sólo unos cuantos apuntes que a lo mejor sirven para ayudar a alguien. Cualquiera que tenga experiencia con esto, por favor anímate a hacer tu aportación. Porque la gente lleva mucho tiempo chinándose tras pasar horas y horas instalando y reinstalando.

1- El keygen (suponiendo que lo tengas) necesita java para funcionar. Puedes buscar el keygen por ahí, hay torrents bajo el nombre "crackandpsadatevalidator". Los hay que en una misma ventana dejan escoger la marca (Peugeot o Citroen) y otros que tienen una aplicación para cada marca. Yo tenía el keygen para la versión de 2011 y me ha servido sin problemas para la de 2013.

2- Con el keygen venía PSA_Date_Validator, otro programa java, que se supone sirve para generar un archivo "infos" crackeado, de manera que se pueda uno saltar el límite de tiempo impuesto por PSA. Pero venía sin instrucciones, de manera que no he conseguido generar nada con él, y además en el torrent de 2013 ya vienen los "infos" generados con validez hasta 2031. Si alguien sabe usar el PSA Date Validator, soy todo oídos. Mientras, más vale usar los "infos" que vienen con el torrent.

3- En todas partes te dicen que puedes usar DaemonTools para montar las ISOs en un DVD virtual, pero no te avisan que, a menos que actives el SPDT, el instalador de ServiceBox se agilipollará al pasar al DVD3, de modo que te pide el DVD3 una y otra vez aunque ya lo tengas montado. Alcohol 120%, instala el SPDT por defecto. Pero si se va a usar Alcohol, hay que buscar una versión completa pirata, porque si intentamos usar una demo gratuita nos obligan a instalar un montón de mierda. DaemonTools al menos da la opción de instalar la mierda o no (y es mucha menos mierda y mucho menos apestosa). El menú Dispositivos->Opticos de virtualbox es capaz de sacar adelante la instalación sin este error, igual que DaemonTools o Alcohol.

4- Si optas por la alternativa de tostar los 3 DVDs (de doble capa, 8,5 GB), más vale asegurarse que:

a) los grabas a la velocidad más baja posible (4x o menos)

b) haces un checksum de los buenos para comprobar que la ISO se ha tostado correctamente. El checksum MD5 que se usa por defecto, no es lo bastante bueno, y más vale usar SHA1 o mejor SHA256. En mi caso, grabar a 8-12x con checksum MD5 produjo DOS DVDs erróneos a pesar que el sistema me decía que todo había ido bien y que el DVD recién grabado había salido "como es debido".

5- De todas todas he tenido que buscar el archivo MSVCR71.DLL y copiarlo en C:\WINDOWS\System32. Este archivo viene de .NET 1.1, y es el propio servicebox quien lo instala, pero hasta no buscarlo y copiar-pegar en system32, no funcionaba nada. Hay veces que te avisa que falta y otras que no te avisa pero te sigue faltando.

6- Tras instalar, hacer clic en los iconos del escritorio arranca el programa correspondiente, ya sea SEDRE o DocBackup. Esto quiere decir que en la bandeja del sistema (parte inferior derecha de la pantalla) te aparece un icono que parpadea. Cuando deja de parpadear se supone que puedes hacer clic en él y que eso abre una ventana de internet explorer. Bien, ocurre lo siguiente:

a) El icono puede que parpadee y puede que no.

b) Tarda *minutos* en estar listo para arrancar (supongo que mientras arranca apache-tomcat-java, carga los datos y toda la demás parafernalia). Espera que te avise que ya está listo antes de clicarlo.

c) DocBackup sí que lanza internet explorer (no hace falta ni clicarlo, lo hace él solito) pero SEDRE *no*. Hay que abrir internet explorer a mano y meterle esta dirección: http://127.0.0.1:6093/Sdr/logon.jsp

d) SEDRE puede que muestre los esquemas eléctricos y puede que no. Si los muestra, HAZ UNA COPIA DE SEGURIDAD COMPLETA YA MISMO!. Puede dejar de funcionar mañana, o dentro de diez minutos. Incluso aunque funcione, es posible que tenga errores con algunos esquemas. Si no muestra los esquemas, más vale que lo dejes correr y te conformes con usar DocBackup.

7- Ninguna de las "soluciones" publicadas soluciona lo de los esquemas eléctricos de SEDRE, y si me equivoco y alguien sabe cómo solucionarlo, por favor que diga con pelos y señales cuál es esa solución. Cuando se presenta el problema, da lo mismo qué navegador se use; IExplorer, Firefox, Opera... hay quien habla de ActiveX, pero eso ha de ser una chorrada. Cierto que ActiveX siempre ha sido una mierda pinchada en un palo. Incluso en windows 10 la movida ActiveX ha sido desterrada del sistema: ya era hora. Firefox-Mozilla *nunca* ha tenido ActiveX para nada, pero cuando aparece el problema, da error "XML mal formado". Cosa que apunta directamente al servidor como responsable, no a los navegadores.

Me he fijado que cada aplicación usa su propia máquina Java (1.47 y 1.50, si no recuerdo mal) No me he metido en esto, pero supongo que en una de ellas habrá DLLs para, digamos, ponerle las cosas fáciles a Microsoft y su Internet Explorer, y que de ahí viene toda la historia. El hecho de que SEDRE falle , probablemente tiene que ver con la aplicación de visualización que usa para desplazar el esquema dentro de la ventana de InternetExplorer. A pesar de todo lo que se dice en los foros, cuando funciona, no hace falta tener cargado el SVGViewer dentro de IE. Cuando no funciona, tener el SVGViewer o no, no hace ninguna diferencia tampoco. Firefox hace mucho que tiene la capacidad de mostrar SVGs sin necesidad de añadirle nada. En cuanto a Opera, la única vez en mi vida que lo he instalado ha sido ahora, porque en otro foro decían que no daba estos problemas. También esto ha resultado ser falso y viene a dar el mismo error "XML mal formado".

En fin: A lo mejor ahora que ActiveX ha ido al crematorio, aparece una versión nueva de SEDRE que dé menos problemas... entretanto, a menos que aparezcan los caballeros programadores de la tabla redonda, más vale dejarlo correr.

Un saludo
 #211319  por americandeivid
 16 May 2020, 20:55
Bueno pues como os he comentado en mi presentación os pongo tutorial para que os funcione perfectamente el SEDRE.

Salva Martínez de Murcia es el autor lo he estado viendo con él hoy. Tiene un C5 restyling. Intentó registrarse y no pudo.

No me fío mucho de las páginas de alojamiento gratuito de imágenes. Con el tiempo se pierden. Ya me pasó otras veces con imageshack y postimage. Por favor que se ponga alguien en contacto conmigo para que le envíe el pdf original.

Imagen
Imagen
Imagen
Imagen
Imagen
Imagen

Que lo disfrutéis.

Un saludo.-
Última edición por americandeivid el 16 May 2020, 22:24, editado 1 vez en total.
 #211320  por Paxeco
 16 May 2020, 21:05
bravo: bravo: bravo: bravo: bravo: bravo: bravo: bravo: bravo: bravo: bravo: bravo: